Prepare-overlay service: check for mountpoint before removing workdir

The service was getting called twice, resulting in a removal of the
overlayfs workdir while the overlay was mounted. Solve this by checking
if the /etc overlay is mounted yet before removing the workdir. Need to
add mountpoint to busybox for this.

Resolves openbmc/openbmc#2429

Change-Id: I407a07dcc3f3856af12a7f3a52966fe7c3d756c3
Signed-off-by: Edward A. James <eajames@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend b/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
index 39a6033..e6678fc 100644
--- a/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
@@ -1,4 +1,5 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://busybox.cfg"
 SRC_URI += "file://flash.cfg"
+SRC_URI += "file://mountpoint.cfg"
 SRC_URI += "file://0001-Stop-watchdog-first-on-startup.patch"