meta-ampere: mtmitchell: ipmi: support on-board sensor report

Support to report sensor information via IPMI for on-board sensors

Tested:
1. Check sensor report using IPMI sdr command:
$ ipmitool sdr list
OutletTemp       | 28 degrees C      | ok
Psu1InletTemp2   | 32 degrees C      | ok
PcieZoneTemp1    | 30 degrees C      | ok
Psu0InletTemp2   | 29 degrees C      | ok
PcieZoneTemp2    | 28 degrees C      | ok

Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com>
Change-Id: Ia38519c79596f65f780fe105ee25e8890825a44f
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 331c244..5973cdf 100644
--- a/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1,10 +1,10 @@
 FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
 
 SRC_URI += "\
-            file://${MACHINE}_gpio_defs.json \
+            file://mtmitchell_gpio_defs.json \
            "
 
 do_install:append() {
 	install -d ${D}${sysconfdir}/default/obmc/gpio/
-	install -m 0644 ${WORKDIR}/${MACHINE}_gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/gpio_defs.json
+	install -m 0644 ${WORKDIR}/mtmitchell_gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/gpio_defs.json
 }