subtree updates

meta-security: 3d9dab6d14..7eed4a60f5:
  Armin Kuster (2):
        linux-yocto.bbappend: bump to kernel version 6.x
        meta-tpm: bump linux-yocto to 6.x kernel

  Max Krummenacher (1):
        samhain: rework due to changed cache handling

meta-openembedded: 2ab113e8be..ea63f13846:
  Beniamin Sandu (1):
        mbedtls: export source files/headers needed by ATF

  Khem Raj (13):
        poco: Do not use std::atomic<bool>
        libwebsockets: Fix build with gcc13
        v4l-utils: Fix build with gcc13
        proj: Upgrade to 9.1.1 release
        mpd: Upgrade to 0.23.12 release
        geos: Upgrade to 3.9.4
        geos: Fix build with gcc13
        libinih: Upgrade to version 56
        python3-pybind11: Upgrade to 2.10.3
        waylandpp: Fix build with gcc-13
        sedutil: Fix build with gcc13
        usbguard: Fix build with gcc13
        minifi-cpp: Fix build with gcc13

  Martin Jansa (6):
        keyutils: fix Upstream-Status formatting
        gphoto2: fix Upstream-Status formatting
        .patch: fix Upstream-Status formatting issues reported by patchreview tool from oe-core
        android-tools: fix Upstream-Status formatting
        mm-common: fix Upstream-Status formatting
        .patch: fix Signed-off-by formatting issues reported by patchreview tool from oe-core

poky: 5e249ec855..29afbb5e14:
  Alejandro Hernandez Samaniego (1):
        newlib: Upgrade 4.2.0 -> 4.3.0

  Alexander Kanavin (1):
        gdk-pixbuf: do not use tools from gdk-pixbuf-native when building tests

  Armin Kuster (1):
        lttng-modules: Fix for 5.10.163 kernel version

  Khem Raj (3):
        valgrind: Include missing <cstdint>
        webkitgtk: Fix build with gcc 13
        gdb: Define alignof using _Alignof when using C11 or newer

  Richard Purdie (3):
        make-mod-scripts: Ensure kernel build output is deterministic
        bitbake.conf: Inject a dash into PN for BB_HASH_CODEPARSER_VALS
        scripts/bitbake-prserv-tool: Fix to work with memres bitbake

  Ross Burton (1):
        Revert "cve-update-db-native: show IP on failure"

meta-arm: 3d51e1117d..aecbb77f72:
  Jon Mason (4):
        arm/qemuarm-secureboot: Changes for v2023.01 u-boot
        arm-bsp/juno: update to use u-boot v2023.01
        arm-bsp/juno: update kernel patches for 6.1
        arm-bsp/fvp-base: update kernel config to remove warning
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ia335876b7ce9a4c9d19ca41ae321b266b3b6d00e
diff --git a/poky/meta/recipes-core/meta/cve-update-db-native.bb b/poky/meta/recipes-core/meta/cve-update-db-native.bb
index e042e67..079f062 100644
--- a/poky/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/poky/meta/recipes-core/meta/cve-update-db-native.bb
@@ -130,10 +130,7 @@
                 response = urllib.request.urlopen(meta_url, timeout=cve_socket_timeout)
             except urllib.error.URLError as e:
                 cve_f.write('Warning: CVE db update error, Unable to fetch CVE data.\n\n')
-                bb.warn("Failed to fetch CVE data (%s)" % e)
-                import socket
-                result = socket.getaddrinfo("nvd.nist.gov", 443, proto=socket.IPPROTO_TCP)
-                bb.warn("Host IPs are %s" % (", ".join(t[4][0] for t in result)))
+                bb.warn("Failed to fetch CVE data (%s)" % e.reason)
                 return False
 
             if response: