meta-nicole: Enable field mode

Enables the field mode by default.
This marks the BMC as production version and activates some production
specific functionalities.
For example, this makes the software manager to discard unverified
firmware images.

Tested:
 - The output of `fw_printenv` contains `fieldmode=true`.
 - `busctl get-property xyz.openbmc_project.Software.BMC.Updater \
          /xyz/openbmc_project/software \
          xyz.openbmc_project.Control.FieldMode FieldModeEnabled`
   returns `true`

(From meta-yadro rev: ca760a233b348efaf860e0691ea4b3f1c0db1ec1)

Change-Id: I9c6fbead319f3c990efba669c923dccb97110e16
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
index f0ff09e..bf7802a 100644
--- a/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -2,4 +2,5 @@
 
 SRC_URI_append = " \
     file://0001-Add-system-reset-status-support.patch \
+    file://0002-config-ast-common-set-fieldmode-to-true.patch \
     "