meta-openpower: convert op-proc-control to meson

This includes the following bump: e22e8231c4..e04c1173c1

Andrew Geissler (3):
      gitignore: ensure utest.cpp not ignored
      meson: remove old automake files
      meson: fix static initialization order race condition

Jayanth Othayoth (1):
      Fix related P10 SPI mux settings

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Iff99f6536d2552984bb08c2e3267c36cde1bf8d4
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index aa0a784..f961198 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -7,19 +7,20 @@
 
 S = "${WORKDIR}/git"
 
-inherit autotools obmc-phosphor-utils pkgconfig
+inherit meson obmc-phosphor-utils pkgconfig
 inherit systemd
 
 SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "e22e8231c49d3a7fa4ea24d57e48be072e1d7e16"
+SRCREV = "e04c1173c1d76575fd1cf968d421bdf1dec82606"
 
 DEPENDS += " \
-        autoconf-archive-native \
         phosphor-logging \
         phosphor-dbus-interfaces \
         libgpiod \
         "
 
+EXTRA_OEMESON += "-Dtests=disabled"
+
 # For libpdbg, provided by the pdbg package
 DEPENDS += "pdbg"