meta-ampere: obmc-console: various fixes

obmc-console configurations are missing some service appending, this
commit adds these.
Remove socket connection check in ampere_uartmux_ctrl.sh for meta-jade
because no socket file is used now in obmc-console.

Tested:
$ ampere_uartmux_ctrl <uart_port> <mux>
Can successfully switch between console header and BMC for host uart
ports
$ ssh root@<BMC_IP> -p <client_port>
Can successfully connect to host console uarts

Signed-off-by: Chau Ly <chaul@amperecomputing.com>
Change-Id: Iaa0c4d8f9045fc94f6f50822516aaac0b99f088e
diff --git a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
index 38040f4..26a356d 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,21 +1,22 @@
 FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
 RDEPENDS:${PN} += "bash"
 
-# Remove what installed by common recipe
-OBMC_CONSOLE_HOST_TTY = ""
-SYSTEMD_SUBSTITUTIONS:remove = "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
-
 # Declare port spcific config files
 OBMC_CONSOLE_TTYS = "ttyS0 ttyS1 ttyS2 ttyS3"
 CONSOLE_CLIENT = "2200 2201 2202 2203"
 
 CONSOLE_SERVER_CONF_FMT = "file://server.{0}.conf"
 CONSOLE_CLIENT_CONF_FMT = "file://client.{0}.conf"
+CONSOLE_CLIENT_SERVICE_FMT = "obmc-console-ssh@{0}.service"
 
-SRC_URI += " ${@compose_list(d, 'CONSOLE_SERVER_CONF_FMT', 'OBMC_CONSOLE_TTYS')} \
+SRC_URI += " \
+             ${@compose_list(d, 'CONSOLE_SERVER_CONF_FMT', 'OBMC_CONSOLE_TTYS')} \
              ${@compose_list(d, 'CONSOLE_CLIENT_CONF_FMT', 'CONSOLE_CLIENT')} \
            "
 
+SYSTEMD_SERVICE:${PN}:append = " \
+                                  ${@compose_list(d, 'CONSOLE_CLIENT_SERVICE_FMT', 'CONSOLE_CLIENT')} \
+                                "
 SYSTEMD_SERVICE:${PN}:remove = "obmc-console-ssh.socket"
 
 FILES:${PN}:remove = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"