meta-phosphor: inventory: enable non-native recipes

There exists a number native class recipes throughout meta-phosphor
that simply provide a data (often YAML) file as input to building
another application.

Having these data file recipes implemented as native class recipes
prevents the use of machine overrides because bitbake (rightfully so)
discards machine qualifiers from native recipes.  Further, data files
aren't really any different than library header files and those are
consumed by recipes as target class recipes that are DEPENDed on.  Do
the same thing for data file recipes.

(From meta-phosphor rev: 1675a60bc9648cb5c7ec224df3791dbe89f09134)

Change-Id: I7fa23c7914abc5018f6534a8daa0462c6ee9daa3
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
new file mode 100644
index 0000000..2dd6e28
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Recipe to create AssetTag property in inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+PROVIDES += "virtual/phosphor-inventory-manager-assettag"
+S = "${WORKDIR}"
+
+SRC_URI = "file://assettag.yaml"
+
+do_install() {
+        install -D assettag.yaml ${D}${base_datadir}/events.d/assettag.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/assettag.yaml"