Make upstream ipmitool.bb handle most configuration tasks

The openembedded ipmitool bitbake file is being updated to be
responsible for handling more build features for the OpenBMC ipmitool.

The openembedded bb file has already been modified to pull ipmitool
source from the codeberg.org repo. It is preferred that the OpenBMC
ipmitool follow the openembedded recipe for the source repo, and
revision.

The codeberg ipmitool repository includes changes that manage the
IANA numbers file. Instead of using rules to manage IANA numbers in
this layer, use the meta-oe rules. The meta-oe rules assume the IANA
numbers file has already been downloaded locally, improving build
repeatability.

Tested:
Confirmed the ipmitool version is no longer 1.8.18
The --enable/disable-registry-download works as expected.
The iana-enterprise-numbers is copied to
/usr/share/misc/enterprise-numbers by the upstream recipe.

Change-Id: I78231ca857581c92c1c5106f3f32256b5fa88332
Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index 28a1524..5445c9d 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -1,10 +1,6 @@
 LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 DEPENDS += "systemd"
-SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
-PV = "1.8.18+git${SRCPV}"
-
-SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
 
 # Temporary patch for https://codeberg.org/IPMITool/ipmitool/pulls/1
 SRC_URI += " \
@@ -13,7 +9,7 @@
 
 # TODO: when a new company joins the OpenBMC project by signing
 #       a CLA, if they have an enterprise number on file with the
-#       IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
+#       IANA, the versioned file, $PWD/ipmitool/iana-enterprise-numbers
 #       needs to be updated to add their entry. The canonical
 #       version of the file is locatede here:
 #       https://www.iana.org/assignments/enterprise-numbers
@@ -21,19 +17,9 @@
 #       This file is manually downloaded so it can be versioned
 #       instead of having the makefile download it during do_compile
 SRC_URI += " \
-    file://enterprise-numbers \
+    file://iana-enterprise-numbers \
     "
 
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
-
-do_compile:prepend() {
-    # copy the SRC_URI version of enterprise-numbers
-    # to the build dir to prevent a fetch
-    mkdir -p "${WORKDIR}/build"
-    cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
-}
-
-# make sure that the enterprise-numbers file gets installed in the root FS
-FILES:${PN} += "${datadir}/misc/enterprise-numbers"