meta-phosphor: disable phosphor-dbus-monitor by default

phosphor-dbus-monitor still uses autoconf and has a hard dependency on
phosphor-snmp, causing phosphor-snmp to be brought in on systems that
have no interest in using SNMP.  The vast majority of systems do not
supply any config for phosphor-dbus-monitor, so the usage of it does not
seem wide enough to enable the IMAGE_FEATURE by default.

- Remove 'obmc-dbus-monitor' from IMAGE_FEATURE by default.
- Clean up all systems that manually remove the dbus-monitor feature or
  package.
- Explicitly add the 'obmc-dbus-monitor' to the following systems:
    - meta-ibm: all
    - meta-inspur: fp5280g2
    - meta-quanta: s6q

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Iad6c4104466e21d1b9843dac964a634019eb6935
diff --git a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 1da8711..cf4093f 100644
--- a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -2,6 +2,8 @@
 OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
 OBMC_IMAGE_EXTRA_INSTALL:append:mihawk = " mboxd liberation-fonts uart-render-controller "
 
+IMAGE_FEATURES:append = " obmc-dbus-monitor"
+
 # remove so things fit in available flash space
 IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap"
 IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry"