build phosphor-hwmon with meson

The repository supports it, so switch it over in bitbake.

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: I8d96c79b395ee2614ddd869091569f245426c5c7
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
index 6958eac..3a11ec7 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -5,14 +5,11 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 inherit obmc-phosphor-systemd
 
 PACKAGECONFIG ??= ""
-# Autotools configure option to enable/disable max31785-msl
-PACKAGECONFIG[max31785-msl] = "--enable-max31785-msl, --disable-max31785-msl"
-# Meson configure option to enable/disable max31785-msl
-# PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
+PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
 
 PACKAGE_BEFORE_PN = "max31785-msl"
 SYSTEMD_PACKAGES = "${PN} max31785-msl"