python-*: use pypi class

Cleanup the various python-* recipes which download from pypi. The
biggest change is to "inherit pypi" which should result in us always
using current pypi best practices. This will for example ensure we are
using https and not http.

Change-Id: I3e818284efb8094e64b004af22781c8a3fcb89b3
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
index ce19f99..318171c 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
+++ b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
@@ -1,5 +1,3 @@
-SRCNAME = "inflection"
-SRC_URI = "https://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=tarball"
-SRC_URI[tarball.sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
-SRC_URI[tarball.md5sum] = "7941165e9f148e0520023941c0886b40"
+SRC_URI[sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
+SRC_URI[md5sum] = "7941165e9f148e0520023941c0886b40"
 require python-inflection.inc