meta-yadro: vegman: led-manager configuration

This brings LEDs description for phosphor-led-manager. This
configuration only describes LED groups.

Real LED control will be introduced in later commits with
phosphor-dbus-monitor configuration once we set other required
components.

Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com>
Change-Id: I74b9f86b9d2c43d8b4f5728f330fe06b19b1e08a
diff --git a/meta-yadro/meta-vegman/recipes-phosphor/leds/rx20-led-manager-config-native.bb b/meta-yadro/meta-vegman/recipes-phosphor/leds/rx20-led-manager-config-native.bb
new file mode 100644
index 0000000..76b57eb
--- /dev/null
+++ b/meta-yadro/meta-vegman/recipes-phosphor/leds/rx20-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for VEGMAN-Rx20"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Overwrite the example led layout yaml file prior
+# to building the phosphor-led-manager package
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}