systemd-journald: Don't store debug messages

Change the default log level from "debug" to "info" for
the messages that are stored on disk and forwarded to
syslog, so that debug messages don't fill up the journal
and more important ones are lost when the journal file
rotates.

Tested: Verified that debug messages such as the ipmi
"IPMI SET_SENSOR" ones are not printed anymore.

(From meta-phosphor rev: 3692b801b4f273905b87b6de2e61ba3839dae4f0)

Change-Id: I84a88511ed2ff90d0b3c2a77ae968cddcff6899f
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb b/meta-phosphor/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
index 930d447..9a9f2bc 100644
--- a/meta-phosphor/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
+++ b/meta-phosphor/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
@@ -7,11 +7,14 @@
 
 DEPENDS += "systemd"
 
-SRC_URI = "file://service-restart-policy.conf"
+SRC_URI += "file://service-restart-policy.conf"
+SRC_URI += "file://journald-maxlevel-policy.conf"
 
 FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
+FILES_${PN} += "${systemd_unitdir}/journald.conf.d/journald-maxlevel-policy.conf"
 
 
 do_install() {
         install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
+        install -m 644 -D ${WORKDIR}/journald-maxlevel-policy.conf ${D}${systemd_unitdir}/journald.conf.d/journald-maxlevel-policy.conf
 }