poky: sumo refresh eebbc00b25..64a257fa22

Update poky to sumo HEAD.

Armin Kuster (1):
      dhcp: allow for excluding the external bind

Awais Belal (1):
      bitbake: bitbake: toaster: allow OE_ROOT to be provided through environment

Changqing Li (2):
      unzip: fix for CVE-2018-18384
      curl: fix for CVE-2018-16839/CVE-2018-16840/CVE-2018-16842

Fabien Lahoudere (1):
      archiver: Drop unwanted directories

Ioan-Adrian Ratiu (1):
      wic: isoimage-isohybrid: fix UEFI spec breakage

Kosta Zertsekel (1):
      meta: Use double colon for chown OWNER:GROUP

Matthias Schiffer (1):
      base.bbclass: avoid 'find -ignore_readdir_race -delete'

Mohamad Noor Alim Hussin (1):
      oeqa/selftest/recipetool: Fix problems from changing upstream source

Peter Kjellerstedt (4):
      common-licenses: Correct the FreeType license text
      apr: Trim license info extracted from apr_lib.h
      apr-util: Trim license info extracted from apu_version.h
      pixman: Trim license info extracted from pixman-matrix.c

Richard Purdie (4):
      oeqa/selftest/wic: Use a subdir of builddir, not /var/
      oeqa/selftest/wic: Ensure initramfs exists for test_iso_image
      selftest/wic: Improve error message for test_fixed_size
      crosssdk: Remove usage of host flags for cross-compilation

Ross Burton (3):
      unzip: actually apply CVE-2018-18384
      curl: actually apply latest CVE patches
      gnupg: patch gnupg-native to allow path relocation

Scott Rifenbark (1):
      kernel-dev: Updated phrasing for what a "defconfig" file is.

Change-Id: I08f7fbe91f3f7ed6f00b6ea691c33ee1e0d3205b
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/archiver.bbclass b/poky/meta/classes/archiver.bbclass
index 31c9b7e..d68add9 100644
--- a/poky/meta/classes/archiver.bbclass
+++ b/poky/meta/classes/archiver.bbclass
@@ -267,6 +267,14 @@
         create_tarball(d, srcdir, 'configured', ar_outdir)
 }
 
+def exclude_useless_paths(tarinfo):
+    if tarinfo.isdir():
+        if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'):
+            return None
+        elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc':
+            return None
+    return tarinfo
+
 def create_tarball(d, srcdir, suffix, ar_outdir):
     """
     create the tarball from srcdir
@@ -291,7 +299,7 @@
 
     bb.note('Creating %s' % tarname)
     tar = tarfile.open(tarname, 'w:gz')
-    tar.add(srcdir, arcname=os.path.basename(srcdir))
+    tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths)
     tar.close()
 
 # creating .diff.gz between source.orig and source