poky: sumo refresh eebbc00b25..64a257fa22

Update poky to sumo HEAD.

Armin Kuster (1):
      dhcp: allow for excluding the external bind

Awais Belal (1):
      bitbake: bitbake: toaster: allow OE_ROOT to be provided through environment

Changqing Li (2):
      unzip: fix for CVE-2018-18384
      curl: fix for CVE-2018-16839/CVE-2018-16840/CVE-2018-16842

Fabien Lahoudere (1):
      archiver: Drop unwanted directories

Ioan-Adrian Ratiu (1):
      wic: isoimage-isohybrid: fix UEFI spec breakage

Kosta Zertsekel (1):
      meta: Use double colon for chown OWNER:GROUP

Matthias Schiffer (1):
      base.bbclass: avoid 'find -ignore_readdir_race -delete'

Mohamad Noor Alim Hussin (1):
      oeqa/selftest/recipetool: Fix problems from changing upstream source

Peter Kjellerstedt (4):
      common-licenses: Correct the FreeType license text
      apr: Trim license info extracted from apr_lib.h
      apr-util: Trim license info extracted from apu_version.h
      pixman: Trim license info extracted from pixman-matrix.c

Richard Purdie (4):
      oeqa/selftest/wic: Use a subdir of builddir, not /var/
      oeqa/selftest/wic: Ensure initramfs exists for test_iso_image
      selftest/wic: Improve error message for test_fixed_size
      crosssdk: Remove usage of host flags for cross-compilation

Ross Burton (3):
      unzip: actually apply CVE-2018-18384
      curl: actually apply latest CVE patches
      gnupg: patch gnupg-native to allow path relocation

Scott Rifenbark (1):
      kernel-dev: Updated phrasing for what a "defconfig" file is.

Change-Id: I08f7fbe91f3f7ed6f00b6ea691c33ee1e0d3205b
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/base.bbclass b/poky/meta/classes/base.bbclass
index abb4ead..2a6a6cb 100644
--- a/poky/meta/classes/base.bbclass
+++ b/poky/meta/classes/base.bbclass
@@ -303,7 +303,9 @@
 			if [ "${CLEANBROKEN}" != "1" -a \( -e Makefile -o -e makefile -o -e GNUmakefile \) ]; then
 				oe_runmake clean
 			fi
-			find ${B} -ignore_readdir_race -name \*.la -delete
+			# -ignore_readdir_race does not work correctly with -delete;
+			# use xargs to avoid spurious build failures
+			find ${B} -ignore_readdir_race -name \*.la -type f -print0 | xargs -0 rm -f
 		fi
 	fi
 	if [ -n "${CONFIGURESTAMPFILE}" ]; then