blob: 19c7652757af9f8ebf0f463750de34987e2bb2f9 [file] [log] [blame]
SUMMARY = "A Python generic test automation framework"
DESCRIPTION = "Generic open source test atomation framework for acceptance\
testing and acceptance test-driven development (ATDD). It has easy-to-use\
tabular test data syntax and it utilizes the keyword-driven testing approach.\
Its testing capabilities can be extended by test libraries implemented either\
with Python or Java, and users can create new higher-level keywords from\
existing ones using the same syntax that is used for creating test cases."
HOMEPAGE = "http://robotframework.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
inherit pypi setuptools3
PYPI_PACKAGE_EXT = "zip"
SRC_URI[sha256sum] = "6a9c06deb220099990f190c6e4e772675f625e4d5d84640fca6f0ad46ff538d0"
RDEPENDS:${PN} += " \
${PYTHON_PN}-shell \
${PYTHON_PN}-pprint \
${PYTHON_PN}-xml \
${PYTHON_PN}-difflib \
${PYTHON_PN}-threading \
${PYTHON_PN}-html \
${PYTHON_PN}-docutils \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-logging \
${PYTHON_PN}-numbers \
${PYTHON_PN}-profile \
"