meta-phosphor: add phosphor-ipmi-ethstats package

Add the phosphor-ipmi-ethstats package.  This package handles OEM IPMI
commands that are meant to return ethernet device statistics.

Tested: Verified the library was compiled and installed when added to
obmc-phosphor-image.
(From meta-phosphor rev: af57049ef8d2d1001dc0ccd9cdf33cac6dcdbff6)

Change-Id: Ic2c5f2020c01aea3bd2477127bec74149beffb79
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb
new file mode 100644
index 0000000..014ae2e
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
+DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-host"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats"
+SRCREV = "d26fff4ecd74aa72433bcb547d95029e4b7b0eb3"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"