u-boot-aspeed: use upstream u-boot.inc

Move u-boot-aspeed-sdk to use u-boot.inc from poki instead our own.  We
still need our own one for old u-boot-aspeed, so keep it as is.

Tested: Build image for AST2500-based machine with
u-boot-aspeed-sdk_2019.04, verified that it boots up and fw-utils
installed to the image properly.

Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com>
Change-Id: Ia5fecdedc94e9550196420884a727e7d87b313d4
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 6c1470a..90e1206 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -19,23 +19,23 @@
 inherit uboot-config
 
 do_compile () {
-	oe_runmake ${UBOOT_MACHINE}
+	oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
 	oe_runmake envtools
 }
 
 do_install () {
 	install -d ${D}${base_sbindir}
-	install -d ${D}${sysconfdir}
-	install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
-	install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+	install -m 755 ${B}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+	ln -sf fw_printenv ${D}${base_sbindir}/fw_setenv
 
+	install -d ${D}${sysconfdir}
 	install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
 }
 
 do_install:class-cross () {
 	install -d ${D}${bindir_cross}
-	install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
-	install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+	install -m 755 ${B}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+	ln -sf fw_printenv ${D}${bindir_cross}/fw_setenv
 }
 
 SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"