phosphor-dbus-monitor: srcrev bump 8d56d48d5a..8246da0417

George Liu (6):
      Update clang-format
      Fix cppcheck warnings
      meson: Add subprojects file
      meson: Add meson build
      meson: Add test meson build
      Fix getting absolute path to YAML_PATH

Signed-off-by: George Liu <liuxiwei@inspur.com>
Change-Id: Ica02c402dd769659e5da19e656e23120b90a4955
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
index 0dc0849..9a99841 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
@@ -7,9 +7,9 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor;branch=master;protocol=https"
-SRCREV = "8d56d48d5a80aa896637161ac01cdb290f358cca"
+SRCREV = "8246da041721dc84f7db3ef9573e311ea46fa11e"
 
-inherit autotools \
+inherit meson \
         pkgconfig \
         python3native \
         phosphor-dbus-monitor \
@@ -22,7 +22,6 @@
 DEPENDS += " \
         ${PN}-config \
         phosphor-logging \
-        autoconf-archive-native \
         ${PYTHON_PN}-sdbus++-native \
         sdeventplus \
         gtest \
@@ -37,6 +36,6 @@
 
 S = "${WORKDIR}/git"
 
-EXTRA_OECONF = " \
-        YAML_PATH=${STAGING_DIR_HOST}${config_dir} \
+EXTRA_OEMESON = " \
+        -DYAML_PATH=${STAGING_DIR_HOST}${config_dir} \
         "