meta-facebook: bb file changes in fb-ipmi-oem.

parsed machine name to meson from bb file to
identify and copy the machine-specific JSON to a machine.

Tested: Tested and verified with yosemitev2 and tiogapass platform.

Signed-off-by: Karthikeyan Pasupathi <pkarthikeyan1509@gmail.com>
Change-Id: Ib891a9cef232f981ede61567953888870296a248
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
index b7618a1..377fe35 100755
--- a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -16,15 +16,14 @@
 
 EXTRA_OEMESON="-Dtests=disabled -Dbic=enabled -Dhost-instances='${OBMC_HOST_INSTANCES}'"
 EXTRA_OEMESON:remove:yosemitev2 = "-Dbic=enabled"
+EXTRA_OEMESON="-Dmachine='${MACHINE}'"
 
 LIBRARY_NAMES = "libzfboemcmds.so"
 
 HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
 NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
 
-FILES:${PN}:append = " ${datadir}/lcd-debug/post_desc.json"
-FILES:${PN}:append = " ${datadir}/lcd-debug/gpio_desc.json"
-FILES:${PN}:append = " ${datadir}/lcd-debug/cri_sensors.json"
+FILES:${PN}:append = " ${datadir}/lcd-debug/*.json"
 
 FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"