meta-phosphor: disable 'uninative' for RHEL6 support

The uninative stub from Yocto-2.2 includes a glibc that
no longer has legacy kernel support for the kernel in
RHEL6.  We need to disable uninative and set OLDEST_KERNEL
to enable backwards compatibility.

See openbmc/openbmc#1407 to track removal of this.

Change-Id: I6352514016d803b7b77d483425b3f080eef896c0
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index e769356..72ef9b1 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -24,6 +24,10 @@
 inherit obmc-phosphor-license
 inherit obmc-phosphor-utils
 
+# TODO: openbmc/openbmc#1407 - Remove with RHEL6 support deprecation.
+#     Set supported kernel back to RHEL6.4's kernel.
+SDK_OLDEST_KERNEL = "2.6.32"
+
 FEATURE_PACKAGES_obmc-bmc-state-mgmt ?= "packagegroup-obmc-apps-bmc-state-mgmt"
 FEATURE_PACKAGES_obmc-chassis-mgmt ?= "${@cf_enabled(d, 'obmc-phosphor-chassis-mgmt', 'virtual-obmc-chassis-mgmt')}"
 FEATURE_PACKAGES_obmc-chassis-state-mgmt ?= "packagegroup-obmc-apps-chassis-state-mgmt"