meta-ampere: gpio-monitor: move services to meta-common

Move services that are used across Ampere platform to
meta-ampere/meta-common to prevent duplicate codes.

Tested:
1. Compile Mt.Jade and Mt.Mitchell without error.
2. From Host OS run 'reboot' command and check if the BMC handles
   correctly.
3. From Host OS run 'shutdown' command and check if the BMC handles
   correctly

Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Change-Id: I678d9a19fea0a531ad59d54ea9386cb177af18c6
diff --git a/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
new file mode 100644
index 0000000..f8cf1d4
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SYSTEMD_SERVICE:${PN}-monitor += " \
+                                  ampere-host-shutdown-ack@.service \
+                                  ampere_overtemp@.service \
+                                  ampere_hightemp_start@.service \
+                                  ampere_hightemp_stop@.service \
+                                 "
+
+SYSTEMD_LINK:${PN}-monitor:append = " ../phosphor-multi-gpio-monitor.service:multi-user.target.requires/phosphor-multi-gpio-monitor.service"
+