Revert "webui-vue: Add a task to find node licences"

This reverts commit 28d315377d2a902e2d3691159411c18a2ce64a66.

This commit no longer compiles with the latest upstream yocto rebase.
I've spent a few hours trying to fix it but no luck. Regenerating the
files did not help.

The error is the following:
npm verb stack Error: request to https://registry.npmjs.org/archy failed: cache mode is 'only-if-cached' but no cached response is available.

This appears to just be for licensing information so not something
required for the function to work. Revert until a fix can be identified.

Change-Id: I2863ffada3e8b0124fa0cf5194f4407488f08e15
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index 5ae6283..b721b6e 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -9,7 +9,7 @@
 SRCREV = "99706ff21354cfe4550b91f8b5951d36d6a31ccb"
 S = "${WORKDIR}/git"
 
-DEPENDS:prepend = "nodejs-native nlf-native "
+DEPENDS:prepend = "nodejs-native "
 
 # allarch is required because the files this recipe produces (html and
 # javascript) are valid for any target, regardless of architecture.  The allarch
@@ -47,9 +47,3 @@
    find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
 }
 
-do_find_node_licenses() {
-    cd ${S}
-    nlf -s detail > ${LICENSE_DIRECTORY}/${PN}/node-licenses
-}
-
-addtask find_node_licenses after do_compile before do_build