blob: 109b40ce3df8e1125e8b0636cc663654e91e5b8d [file] [log] [blame]
SUMMARY = "A library providing C and Python (libcURL like) API \
for downloading linux repository metadata and packages."
HOMEPAGE = "https://github.com/rpm-software-management/librepo"
DESCRIPTION = "${SUMMARY}"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/rpm-software-management/librepo.git \
file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
"
SRCREV = "88b769eceefc1b151937e6b54d108b48f2177d87"
S = "${WORKDIR}/git"
DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
inherit cmake distutils3-base pkgconfig
EXTRA_OECMAKE = " \
-DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
-DPYTHON_DESIRED=3 \
-DENABLE_TESTS=OFF \
-DENABLE_DOCS=OFF \
-DWITH_ZCHUNK=OFF \
"
BBCLASSEXTEND = "native nativesdk"