pdbg: update to version 1.0

Upstream changelog:
 - Move to a generic description of the hw topography using device-tree
 - General build bugfixes
 - Build libpdbg as a shared library
 - Complete support for POWER9 including get/putmem and register operations
 - Minor code clean-ups

The build now depends on dtc.

Change-Id: If49a212e4d684b72b664086e52ffc5ae4e9aa980
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pdbg/pdbg_1.0.bb b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pdbg/pdbg_1.0.bb
new file mode 100644
index 0000000..3ab2265
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pdbg/pdbg_1.0.bb
@@ -0,0 +1,13 @@
+SUMMARY     = "PowerPC FSI Debugger"
+DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors from the BMC."
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI += "git://github.com/open-power/pdbg.git;branch=master"
+SRCREV = "7c56ba516efa9ad1b6827ec3a90ac76b8f66f907"
+
+DEPENDS += "dtc-native"
+
+S = "${WORKDIR}/git"
+
+inherit autotools