Fix openpower-ipmi-oem error yaml installation

Need the ${D} in the copy destination.

Tested: Check that the errors now show up in the elog-lookup.cpp
        file generated during the build by phosphor-logging.

Change-Id: I70d0b0acde98c697cadd2c4c50f0f16088014ce2
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb
index 837d8b2..b029760 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb
@@ -12,7 +12,7 @@
 
 do_install_append() {
     SRC=${S}/org/open_power/OCC
-    DEST=${yaml_dir}/org/open_power/OCC
+    DEST=${D}${yaml_dir}/org/open_power/OCC
     install -d ${DEST}
     install ${SRC}/Metrics.errors.yaml ${DEST}
     install ${SRC}/Metrics.metadata.yaml ${DEST}