nlohmann-json: Add symlink to json.hpp and update to 3.3.0

nlohmann-json has examples in their repo that refer to
the header as json.hpp directly, as such many packages
that require nlohmann-json expect json.hpp and not
nlohmann/json.hpp as the cmake file installs. Create symlink
so that access is available by either option. Also update
to release 3.3.0.

(From meta-openembedded rev: 69e5fa1485aa58ad1d664070b0d9e4db413fdd62)

Change-Id: Ie43a76e16eb1d1a107e090d544937d6465719d6c
Signed-off-by: James Feist <james.feist@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
index a89b659..65e49bc 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
@@ -6,9 +6,9 @@
 
 SRC_URI = "git://github.com/nlohmann/json.git"
 
-PV = "3.2.0+git${SRCPV}"
+PV = "3.3.0+git${SRCPV}"
 
-SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
+SRCREV = "aafad2be1f3cd259a1e79d2f6fcf267d1ede9ec7"
 
 S = "${WORKDIR}/git"
 
@@ -21,3 +21,9 @@
 RDEPENDS_${PN}-dev = ""
 
 BBCLASSEXTEND = "native nativesdk"
+
+# other packages commonly reference the file directly as "json.hpp"
+# create symlink to allow this usage
+do_install_append() {
+    ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
+}