meta-google: gbmc-bridge: install nft rules for traffic redirection

On bmc connects to multiple CNs, services may want to tell the source of
the traffic. This new package is to install the rules accordingly.

Change-Id: I5df17151cb5056386b5eafdcd4ac1ceb3f37e298
Signed-off-by: Yuxiao Zhang <yuxiaozhang@google.com>
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index d5ee98f..3245eb2 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -28,6 +28,7 @@
   file://gbmc-br-lib.sh \
   file://gbmc-br-load-ip.service \
   file://gbmc-start-dhcp.sh \
+  file://50-gbmc-br-cn-redirect.rules \
   "
 
 FILES:${PN}:append = " \
@@ -113,6 +114,7 @@
   nftables_dir=${D}${sysconfdir}/nftables
   install -d -m0755 "$nftables_dir"
   install -m0644 ${WORKDIR}/50-gbmc-br.rules $nftables_dir/
+  install -m0644 ${WORKDIR}/50-gbmc-br-cn-redirect.rules $nftables_dir/
 
   avahi_dir=${D}${sysconfdir}/avahi/services
   install -d -m 0755 "$avahi_dir"