Reorder dependencies alphabetically

Change-Id: I0bd57e51c8e8c8d5f3de0bd9562a1789f21dfe34
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index ca856da..bd9cdd2 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -5,32 +5,34 @@
 RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
 
 inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
 inherit obmc-phosphor-license
 inherit obmc-phosphor-sdbus-service
-inherit obmc-phosphor-ipmiprovider-symlink
+inherit obmc-phosphor-systemd
 inherit phosphor-ipmi-host
 inherit pythonnative
-inherit obmc-phosphor-systemd
 
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "obmc-targets"
+DEPENDS += "packagegroup-obmc-ipmid-providers"
+DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "phosphor-logging"
 DEPENDS += "phosphor-mapper"
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "packagegroup-obmc-ipmid-providers"
-DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
 DEPENDS += "sdbusplus"
-DEPENDS += "phosphor-dbus-interfaces"
-DEPENDS += "obmc-targets"
+DEPENDS += "sdbus++-native"
 DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
 DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
-DEPENDS += "sdbus++-native"
+DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
 
 RDEPENDS_${PN}-dev += "phosphor-logging"
 RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
 RDEPENDS_${PN} += "clear-once"
-RDEPENDS_${PN} += "network"
 RDEPENDS_${PN} += "libmapper"
+RDEPENDS_${PN} += "network"
+RDEPENDS_${PN} += "phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "phosphor-mapper"
 RDEPENDS_${PN} += "phosphor-time-manager"
-RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "sdbusplus"
 RDEPENDS_${PN} += "virtual/obmc-watchdog"
 
 SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
@@ -60,14 +62,12 @@
 
 NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
 
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
 FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
 
 # Soft Power Off
-RDEPENDS_${PN} += "phosphor-mapper"
-
 # install the soft power off service in the host shutdown target
 SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
 SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"