Move to the upstream IPMI BT kernel driver

The kernel driver for the iBT interface has landed upstream. In the
review process, the location of the device node was changed, as was the
naming of the ioctls and the kconfig symbol.

This change moves to the new version of btbridge, which brings in
autotools support from Matt Barth and a port to the new kernel driver
from Cédric Le Goater. The .bb file is modified to support the autotools
dependencies.

  Convert build process to autotools
  replace bt_host by bt_bmc
  add a --device option
  Corrected resulting errors from -Wall & -Werror.

We update the ast2400 and ast2500 defconfigs with the new config symbol,
and bump the kernel to the latest version. The kernel changes clean up
the old driver, and add the new one, including device tree changes.

  ARM: dts: aspeed: Enable BT IPMI BMC device
  ARM: aspeed: Add defconfigs for CONFIG_ASPEED_BT_IPMI_BMC
  ipmi: add an Aspeed BT IPMI BMC driver
  ARM: dts: aspeed: remove previous iBT definitions
  ARM: aspeed: remove previous definitions in default config
  Revert "misc: Add Aspeed BT IPMI host driver"

Change-Id: I8fcc43deaf5db71d587e34c4e4ed2111e7f3e182
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb
index 9c55cf4..601e5e2 100644
--- a/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb
@@ -4,6 +4,7 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
+inherit autotools pkgconfig
 inherit obmc-phosphor-dbus-service
 
 DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service"
@@ -12,13 +13,14 @@
 RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
 RRECOMMENDS_${PN} += "host-ipmid"
 
+DEPENDS += "autoconf-archive-native"
 DEPENDS += "systemd"
 RDEPENDS_${PN} += "libsystemd"
 
 S = "${WORKDIR}/git"
 SRC_URI += "git://github.com/openbmc/btbridge"
-SRCREV="39b3700766d851009258544aa0f75365f024c597"
+SRCREV="68bcce035ac7029d3110b53fb07848067da56b40"
 
 # This is how linux-libc-headers says to include custom uapi headers
-EXTRA_OEMAKE_append = "CFLAGS=-I${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = "-I ${STAGING_KERNEL_DIR}/include/uapi"
 do_configure[depends] += "virtual/kernel:do_shared_workdir"