Fix YAML overriding.

bitbake tasks use python3, under which filter() returns a filter object
which doesn't enumerate as list. As a result none of the overriding YAMLs
takes effect. Use list expansion instead.

Discussion for context:
https://lists.ozlabs.org/pipermail/openbmc/2017-October/009521.html

Fixes openbmc/openbmc#2469.

Change-Id: I37cc7fc14b6f91c4eb1fb199d7cff52d93c9ad2a
Signed-off-by: Kun Yi <kunyi@google.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
index 169b547..a9955fe 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
@@ -41,7 +41,7 @@
     cmd.append(os.path.join(sensoryamldir, 'config.yaml'))
 
     fetch = os.listdir(sensoryamldir)
-    override_urls = filter(lambda f: f.endswith('-config.yaml'), fetch)
+    override_urls = [url for url in fetch if url.endswith('-config.yaml')]
     for url in override_urls:
         bb.debug(2, 'Merging extra configurations: ' + url)
         filename = os.path.join(sensoryamldir, url)