Add recipes for Phosphor inventory manager

Phosphor Inventory Manager is an inventory object lifecycle
management application suitable for a wide variety of
OpenBMC platforms.

Add recipes.
Add systemd unit.

Change-Id: I4cbaa34b3b787c2ced96efebf36b9b964ddbe8ae
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
new file mode 100644
index 0000000..137733621
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor Inventory Manager Configuration"
+DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
+data to the native /usr/share/phosphor-inventory-manager filesystem."
+HOMEPAGE = "http://github.com/openbmc/phosphor-inventory-manager"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit native
+
+OBMC_INVENTORY_PROVIDERS ??= "phosphor-inventory-manager-config-example-native"
+
+# To add additional managed inventory items, create a recipe in your layer,
+# and add it to OBMC_INVENTORY_PROVIDERS with a bbappend to this recipe.
+
+DEPENDS += "${OBMC_INVENTORY_PROVIDERS}"