Add FSI enable/disable services for cronus use

Start fsi-disable.service to unbind the FSI Driver.
Start fsi-enable.service to bind it again and rescan.

Also added a fsi-bind@.service so we can ensure the
driver is bound each power on.

Change-Id: I5fa62b44994aea3bb645e755187f29e720bf3bce
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb
new file mode 100644
index 0000000..37a326f
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb
@@ -0,0 +1,21 @@
+SUMMARY = "FSI Services"
+DESCRIPTION = "Install FSI related services"
+PR = "r1"
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+TGTFMT = "obmc-power-chassis-on@{0}.target"
+
+TMPL_SCAN = "fsi-scan@.service"
+INSTFMT_SCAN = "fsi-scan@{0}.service"
+FMT_SCAN = "../${TMPL_SCAN}:${TGTFMT}.requires/${INSTFMT_SCAN}"
+
+TMPL_BIND = "fsi-bind@.service"
+INSTFMT_BIND = "fsi-bind@{0}.service"
+FMT_BIND = "../${TMPL_BIND}:${TGTFMT}.requires/${INSTFMT_BIND}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} ${TMPL_BIND} fsi-enable.service fsi-disable.service"
+
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_BIND', 'OBMC_CHASSIS_INSTANCES')}"