simplify setting of KERNEL_DANGLING_FEATURES_WARN_ONLY

Setting this within python is not required

(From meta-phosphor rev: b737ffb23aff232b2ce212ad54171afe7b216a71)

Change-Id: I3d799b5cd9e66c9bc1a4d145274bfa3c06bdf575
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
index 6acd6a6..8dd381e 100644
--- a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -10,9 +10,6 @@
 KERNEL_FEATURES_append = " phosphor-vlan"
 KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"
 
-python () {
-    # OpenBMC loads in kernel features via other mechanisms so this check
-    # in the kernel-yocto.bbclass is not required
-    d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
-}
-
+# OpenBMC loads in kernel features via other mechanisms so this check
+# in the kernel-yocto.bbclass is not required
+KERNEL_DANGLING_FEATURES_WARN_ONLY="1"