obmc-phosphor-image: disable /etc/version file

The /etc/version file is created by image generation with the timestamp
of when the image was built.  This is not useful to users and they
should instead use /etc/os-release.  There appears to be no way to
disable the version file.  Per the following email, delete it as
part of the ROOTFS_POSTPROCESS_COMMAND:
    https://www.mail-archive.com/yocto@yoctoproject.org/msg33555.html

Fixes openbmc/openbmc#1232.

Change-Id: I78b3f31477c8490312be253eb363c4aafadf486c
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index c31b7d7..3b5b559 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -89,3 +89,10 @@
 inherit ${@image_overlay_enabled(d, "image-overlay")}
 
 do_image_complete[depends] += "obmc-phosphor-debug-tarball:do_image_complete"
+
+# The /etc/version file is misleading and not useful.  Remove it.
+# Users should instead rely on /etc/os-release.
+remove_etc_version() {
+        rm ${IMAGE_ROOTFS}${sysconfdir}/version
+}
+ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "