phosphor-bmc-code-mgmt: Add Add static-dual-image config and srcrev bump 88ba1f9ec7..554757b9a8

Add static-dual-image package config to enable/disable the feature for
dual image support for static layout, and install the related services.

Lei YU (13):
      item_updater: Fix crash in updateUbootEnvVars()
      dual-image: Mount alt dirs
      dual-image: Always create os-release symlink
      dual-image: Do not erase image if os-release is not found
      dual-image: Detect the running image slot
      dual-image: Set priority for primary and secondary flash
      dual-image: Add alt-rwfs-dir config
      dual-image: Sync files before sync-manager starts
      dual-image: Remove the functional check on delete
      dual-image: Implement BMC update when running on secondary
      dual-image: remount alt partitions during update
      dual-image: Add reset-cs0-aspeed to reset the CS
      dual-image: Fix the install of obmc-flash-bmc-alt@.service

Change-Id: I71b1356eefe7662ef4a934b100ba1b82aa0cf5dd
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Signed-off-by: Lei YU <yulei.sh@bytedance.com>
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
index da308bc..cf4a053 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
@@ -33,6 +33,7 @@
 PACKAGECONFIG[ubifs_layout] = "-Dbmc-layout=ubi"
 PACKAGECONFIG[mmc_layout] = "-Dbmc-layout=mmc"
 PACKAGECONFIG[flash_bios] = "-Dhost-bios-upgrade=enabled, -Dhost-bios-upgrade=disabled"
+PACKAGECONFIG[static-dual-image] = "-Dbmc-static-dual-image=enabled, -Dbmc-static-dual-image=disabled"
 
 inherit meson pkgconfig
 inherit obmc-phosphor-dbus-service
@@ -48,6 +49,9 @@
     sdbusplus \
 "
 
+# The repo installs several scripts that depends on bash
+RDEPENDS:${PN} += " bash"
+
 RDEPENDS:${PN}-updater += " \
     bash \
     virtual-obmc-image-manager \
@@ -88,6 +92,9 @@
 
 SYSTEMD_SERVICE:${PN}-updater += "${@bb.utils.contains('PACKAGECONFIG', 'flash_bios', 'obmc-flash-host-bios@.service', '', d)}"
 SYSTEMD_SERVICE:${PN}-usb += "${@bb.utils.contains('PACKAGECONFIG', 'usb_code_update', 'usb-code-update@.service', '', d)}"
+SYSTEMD_SERVICE:${PN}-updater += "${@bb.utils.contains('PACKAGECONFIG', 'static-dual-image', 'obmc-flash-bmc-alt@.service', '', d)}"
+SYSTEMD_SERVICE:${PN}-updater += "${@bb.utils.contains('PACKAGECONFIG', 'static-dual-image', 'obmc-flash-bmc-static-mount-alt.service', '', d)}"
+SYSTEMD_SERVICE:${PN}-updater += "${@bb.utils.contains('PACKAGECONFIG', 'static-dual-image', 'obmc-flash-bmc-prepare-for-sync.service', '', d)}"
 
 S = "${WORKDIR}/git"