meta-quanta: gbs: add sensors associations for Redfish

1. add GBS sensors associations for Redfish
2. enable DBUS log service transactions through Redfish option

(From meta-quanta rev: a271b5e4d39d8d57a453f7ea2e500d309241e250)

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: If71fc9e9ec4f47b7dc78bb0940588e801e6e8c45
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-quanta/meta-gbs/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 0000000..0c4b56f
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+        install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"