meta-quanta: gbs: add sensors associations for Redfish

1. add GBS sensors associations for Redfish
2. enable DBUS log service transactions through Redfish option

(From meta-quanta rev: a271b5e4d39d8d57a453f7ea2e500d309241e250)

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: If71fc9e9ec4f47b7dc78bb0940588e801e6e8c45
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
new file mode 100644
index 0000000..205822c
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+PACKAGECONFIG_append_gbs = " associations"
+SRC_URI_append_gbs = " file://associations.json"
+DEPENDS_append_gbs = " inventory-cleanup"
+
+do_install_append_gbs() {
+    install -d ${D}${base_datadir}
+    install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
+}