blob: 32484ce7910f11a2a9fc661e4ef4c9f54c6d7e1e [file] [log] [blame]
SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
complete with lines, arcs, text, multiple colors, cut and paste from other \
images, and flood fills, and to write out the result as a PNG or JPEG file. \
This is particularly useful in Web applications, where PNG and JPEG are two \
of the formats accepted for inline images by most browsers. Note that gd is not \
a paint program."
HOMEPAGE = "http://libgd.github.io/"
SECTION = "libs"
LICENSE = "GD"
LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7"
DEPENDS = "freetype libpng jpeg zlib tiff"
SRC_URI = "git://github.com/libgd/libgd.git;branch=master \
file://0001-replace-uint32-with-uint32_t-and-uint16-with-uint16_.patch \
file://0001-fix-read-out-of-bands-in-reading-tga-header-file.patch \
"
SRCREV = "2e40f55bfb460fc9d8cbcd290a0c9eb908d5af7e"
S = "${WORKDIR}/git"
inherit autotools binconfig gettext pkgconfig
EXTRA_OECONF += " --disable-rpath \
--with-jpeg=${STAGING_LIBDIR}/.. \
--with-freetype=yes \
--without-fontconfig \
--without-webp \
--without-xpm \
--without-x \
"
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
do_install:append:class-target() {
# cleanup buildpaths from gdlib.pc
sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
}
PACKAGES += "${PN}-tools"
FILES:${PN} = "${libdir}/lib*${SOLIBS}"
FILES:${PN}-tools = "${bindir}/*"
PROVIDES += "${PN}-tools"
RPROVIDES:${PN}-tools = "${PN}-tools"
RDEPENDS:${PN}-tools = "perl perl-module-strict"
CVE_PRODUCT = "libgd"
BBCLASSEXTEND = "native nativesdk"