meta-facebook: reduce permissions on scripts

Scripts should be installed with 0755 permissions and not 0777,
otherwise non-root users can potentially modify or delete them.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I41270a2bb3fb940d8ca49ed6230545d98efb2fea
diff --git a/meta-facebook/meta-harma/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/meta-harma/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 358cf3d..954bc39 100644
--- a/meta-facebook/meta-harma/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/meta-harma/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -48,13 +48,13 @@
     install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
 
     install -d ${D}${libexecdir}/${PN}
-    install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
-    install -m 0777 ${WORKDIR}/phosphor-state-manager-init ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/host-poweroff ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/host-poweron ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
+    install -m 0755 ${WORKDIR}/phosphor-state-manager-init ${D}${libexecdir}/${PN}/
 }
 SYSTEMD_OVERRIDE:${PN}-discover:harma += "discover-sys-init.conf:phosphor-discover-system-state@0.service.d/discover-sys-init.conf"
 SYSTEMD_OVERRIDE:${PN}-systemd-target-monitor:harma += "phosphor-state-manager-init.conf:phosphor-systemd-target-monitor.service.d/phosphor-state-manager-init.conf"