Add sysconfdir to default systemd service substitutions

This could be specified as a custom substition by recipes that use it,
but like bindir, sbindir, and envfiledir, it seems common enough that it
should be a default substitution.

Signed-off-by: Xo Wang <xow@google.com>
Change-Id: I827aad06ca8401a22554b87499ba7f33470f438d
diff --git a/meta-phosphor/classes/obmc-phosphor-systemd.bbclass b/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
index 3d7d846..d302ca5 100644
--- a/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
@@ -128,6 +128,7 @@
                 'bindir',
                 'sbindir',
                 'envfiledir',
+                'sysconfdir',
                 'SYSTEMD_DEFAULT_TARGET' ]:
             set_append(d, 'SYSTEMD_SUBSTITUTIONS',
                 '%s:%s:%s' % (x, d.getVar(x, True), file))