treewide: fix append/remove directives

As mentioned by I970e06ca6f9d0a9792af122eb25da1bb9a06f058, append and
remove directives with '+=' are no longer valid Yocto syntax and raise a
warning.

See https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n40

One interesting caveat has to do with the difference between "append"
and "+=".

    foo:append = "a"
    foo:append = "b"

Results in `foo = "ab"`, but

    foo += "a"
    foo += "b"

Results in `foo = "a b"`.  When `:append +=` is used it has behavior
like the `+=` operator.  Therefore, in some cases we need to insert
additional whitespace after the `:append = "` to ensure concatenation
behaves as expected.  I've manually reviewed the results to ensure there
is no ill side-effects from an additional space potentially being added.

Fix up the entire tree with the following one-liner (and similar for
`remove`):

    git ls-files -- ':!:poky/**' ':!:meta-security/**' \
        ':!:meta-raspberrypi/**' ':!:meta-openembedded/**' \
    | grep "\.bb" | xargs grep -l ":append.*+=" \
    | xargs sed -i 's/:append\(.*\)+=\([^"]*\)" */:append\1=\2" /'

  or ...
    | xargs grep -l ":remove.*+=" \
    | xargs sed -i "s/:remove\(.*\)+=/:remove\1=/"

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Iea6235e7c76e252f4d473652957c2925f6b8845a
diff --git a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
index 4956dd7..82705c4 100644
--- a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
+++ b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
@@ -1,11 +1,11 @@
 ALT_RMCPP_IFACE:mihawk = "eth1"
-SYSTEMD_SERVICE:${PN}:append:mihawk += " \
+SYSTEMD_SERVICE:${PN}:append:mihawk = " \
     ${PN}@${ALT_RMCPP_IFACE}.service \
     ${PN}@${ALT_RMCPP_IFACE}.socket \
     "
 
 ALT_RMCPP_IFACE:p10bmc = "eth1"
-SYSTEMD_SERVICE:${PN}:append:p10bmc += " \
+SYSTEMD_SERVICE:${PN}:append:p10bmc = " \
     ${PN}@${ALT_RMCPP_IFACE}.service \
     ${PN}@${ALT_RMCPP_IFACE}.socket \
     "