blob: a627af000cc6e574c78eb1e8ccb0f0b68e0ea459 [file] [log] [blame]
require recipes-graphics/xorg-app/xorg-app-common.inc
SUMMARY = "xterm is the standard terminal emulator for the X Window System"
DEPENDS = "libxaw xproto xextproto libxext libxau libxinerama libxpm ncurses"
LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=842e945c46c43e05c44d95003aa878e1"
SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
SRC_URI[md5sum] = "e78a0bbc4d5fa3780917e447ae8ebc6b"
SRC_URI[sha256sum] = "3b31b07a0c40427e9330ec3be9d1a748c72808f945953cea9e526e48be315f1b"
PACKAGECONFIG ?= ""
PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
--x-libraries=${STAGING_LIBDIR} \
FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
--disable-imake \
--disable-rpath-hack \
--disable-setuid"
B = "${S}"
do_configure() {
gnu-configize --force
sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
oe_runconf
}
FILES_${PN} += "/usr/lib/X11"