meta-phosphor: add a base image recipe

Much like core-image-base, add a base OpenBMC image
obmc-phosphor-base-image.

This is essentially CORE_IMAGE_BASE_INSTALL +
packagegroup-obmc-apps-extras (which is empty by default).

At time of writing, obmc-phosphor-base-image is an abstract thing and
doesn't make any specific statement about content.  The initial intent
is twofold:

1 - Provide a base image upon which space constrained users can "build up"
  their image content by appending to IMAGE_FEATURES in place of the
  current practice of "tearing down" obmc-phosphor-image by _remove-ing from
  IMAGE_FEATURES (The Yocto layering implementation prefers appending over
  _remove-ing for maximum layer compatibility).

2 - Over time, a carefully curated set of IMAGE_FEATURES would be added
  (there aren't any at the moment) that provides content that most
  users would expect by default.

(From meta-phosphor rev: fb768573bc58d020b63dba323cb0eb3afafd5e6d)

Change-Id: Id3b15ffd8084298a4784ad1b3c4004b2cb2f73e4
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image-base.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image-base.bb
new file mode 100644
index 0000000..2d91377
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image-base.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A basic OpenBMC image with no features enabled."
+
+IMAGE_LINGUAS = ""
+LICENSE = "Apache-2.0"
+
+inherit obmc-phosphor-image
+
+# The /etc/version file is misleading and not useful.  Remove it.
+# Users should instead rely on /etc/os-release.
+ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
+
+# Disable the pager to prevent systemd injecting control characters into the
+# output stream that are not interpreted by busybox tools.
+ROOTFS_POSTPROCESS_COMMAND += "disable_systemd_pager ; "