poky: refresh master: 8217b477a1..4e511f0abc

Update poky to master HEAD.

Adrian Bunk (1):
      bind: upgrade 9.11.5 -> 9.11.5-P4

Alexey Brodkin (1):
      busybox: Enable domain search list support

Andre Rosa (2):
      lib/oe/utils: Make prune_suffix prune a suffix
      bitbake: utils: Make prune_suffix prune a suffix

Andreas Müller (1):
      patch/insane: Rework patch fuzz handling

Bruce Ashfield (8):
      poky-tiny: set 5.0 as the preferred kernel
      linux-yocto-rt/4.19: fix duplicate TIF_NEED_RESCHED_LAZY
      linux-yocto/5.0: update CGL audit configuration fragment
      linux-yocto-tiny/4.18: point KBRANCH to 4.18
      linux-yocto/4.18: update to v4.18.33
      qemumips: Enable the poweroff driver
      linux-yocto/5.0: tweak qemuarm -tiny configuration
      linux-yocto/4.18: remove versioned recipes

Gianfranco Costamagna (1):
      kernel-dev, sdk-manual: Unified question spacing

Khem Raj (2):
      libgcc: Create linux-musleabihf and linux-gnueabihf symlinks
      Revert "mdadm: fix gcc8 maybe-uninitialized/format-overflow warning"

Mark Asselstine (2):
      go.bbclass: Export more GO* environment variables
      goarch.bbclass: use MACHINEOVERRIDES and simplify go_map_arm()

Nathan Rossi (3):
      cmake-native: Enable ccmake by default and depend on ncurses
      ccmake.bbclass: Create a cml1 style class for the CMake curses UI
      devtool: standard: Handle exporting generated config fragments

Nikhil Pal Singh (1):
      cmake: Support Eclipse and other cmake generators

Ovidiu Panait (2):
      xf86-video-vesa: Refuse to run on UEFI machines
      ghostscript: Fix 3 CVEs

Randy MacLeod (1):
      autoconf: update runtime perl module dependencies

Richard Purdie (4):
      openssh/util-linux/python*: Ensure ptest output is unbuffered
      ptest-runner: Add several logging fixes
      oeqa/utils/qemurunner: Fix typo in previous commit
      linux-yocto: Drop 4.18 kernel

Robert Yang (1):
      sstate.bbclass: Use bb.utils.to_boolean() for BB_NO_NETWORK

Ross Burton (2):
      sanity: clarify error message if TMPDIR moves
      insane: fix gettext dependency warning

Scott Rifenbark (2):
      ref-manual: Updated BB_GENERATE_MIRROR_TARBALLS
      overview-manual: Fixed broken link to pseudo.

Tomasz Meresiński (1):
      systemd: fix predictable network interface names in initrd

Yeoh Ee Peng (2):
      resulttool/manualexecution: Enable configuration options selection
      resulttool/manualexecution: Enable creation of configuration option file

Change-Id: I988df9d6bf0dfdeaa517960fb744c7388f791cf6
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/go.bbclass b/poky/meta/classes/go.bbclass
index 7069c5f..78c2d68 100644
--- a/poky/meta/classes/go.bbclass
+++ b/poky/meta/classes/go.bbclass
@@ -8,6 +8,25 @@
 export GOROOT
 export GOROOT_FINAL = "${libdir}/go"
 
+export GOARCH = "${TARGET_GOARCH}"
+export GOOS = "${TARGET_GOOS}"
+export GOHOSTARCH="${BUILD_GOARCH}"
+export GOHOSTOS="${BUILD_GOOS}"
+
+GOARM[export] = "0"
+GOARM_arm_class-target = "${TARGET_GOARM}"
+GOARM_arm_class-target[export] = "1"
+
+GO386[export] = "0"
+GO386_x86_class-target = "${TARGET_GO386}"
+GO386_x86_class-target[export] = "1"
+GO386_i586_class-target = "${TARGET_GO386}"
+GO386_i586_class-target[export] = "1"
+
+GOMIPS[export] = "0"
+GOMIPS_mips_class-target = "${TARGET_GOMIPS}"
+GOMIPS_mips_class-target[export] = "1"
+
 DEPENDS_GOLANG_class-target = "virtual/${TUNE_PKGARCH}-go virtual/${TARGET_PREFIX}go-runtime"
 DEPENDS_GOLANG_class-native = "go-native"
 DEPENDS_GOLANG_class-nativesdk = "virtual/${TARGET_PREFIX}go-crosssdk virtual/${TARGET_PREFIX}go-runtime"