blob: 0716a08a4eca208be579040e05110155e9dd5a21 [file] [log] [blame]
SUMMARY = "Security-focused ELF files checking tool"
DESCRIPTION = "This is a small set of various PaX aware and related \
utilities for ELF binaries. It can check ELF binary files and running \
processes for issues that might be relevant when using ELF binaries \
along with PaX, such as non-PIC code or executable stack and heap."
HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz"
SRC_URI[md5sum] = "d731f5385682a7a62ee2e7b7dacc13a7"
SRC_URI[sha256sum] = "f69a9938e4af7912d26d585094bc0203e43571a990fdd048319088a8b8ad906f"
RDEPENDS_${PN} += "bash python"
do_install() {
oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
}
BBCLASSEXTEND = "native"