phosphor: Move ipmitool fork to a set of patches

Given that upstream yocto already has a recipe for ipmitool, it doesn't
make sense for us to have a hard fork of it, especially when they are
solving problems for us, and keep the version up to date.

Functionally, this commit does 3 things.
1. Deletes the phosphor specific phosphor-ipmi-tool target
2. Adds the openbmc specific ipmitool patches into phosphor, for ease of
updating to new versions in the future.
3. Updates ipmitool to the latest upstream version: 1.8.18

Tested By:
Built an image with ipmitool included.  Ran through some basic commands:

ipmitool mc info
ipmitool sensor list

and observed no errors, and correct responses over dbus.

Ran
ipmitool --help

and observed
ipmitool version 1.8.18
in the output string.

(From meta-phosphor rev: fe41c387618414906722b6a60b4c752cb6941d45)

Change-Id: If1f0f3dbf8997576b8001e76318bbc231e8f59c0
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
new file mode 100644
index 0000000..7a34ce4
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+DEPENDS += "systemd"
+
+SRC_URI += "file://0001-plugins-Add-a-backend-for-the-OpenBMC-dbus-interface.patch"