blob: 98977673ee4ce8cdec2cdae53780d78198c3a0c3 [file] [log] [blame]
require go-${PV}.inc
require go-target.inc
inherit linuxloader
CGO_LDFLAGS:append:mips = " -no-pie"
export GO_LDSO = "${@get_linuxloader(d)}"
export CC_FOR_TARGET = "gcc"
export CXX_FOR_TARGET = "g++"
# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
# variants.
python() {
if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel")
}