Add Nuvoton NPCM7XX BSP support

Add as follow :

    1. NPCM7XX Kernel Linux
    2. NPCM7XX U-boot

Change-Id: I84ae09c16725fcf9d23f8daf3c9eadac09cb605f
Signed-off-by: Tomer Maimon <tmaimon77@gmail.com>
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-bsp/u-boot/u-boot-nuvoton_git.bb b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
new file mode 100644
index 0000000..ea1fdbe
--- /dev/null
+++ b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "U-boot for Nuvoton NPCM7xx Baseboard Management Controller"
+
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES += "u-boot"
+
+DEPENDS += "dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+
+S = "${WORKDIR}/git"
+
+UBRANCH = "npcm7xx"
+SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
+SRCREV = "196461383f7d043f18cab3bb34dded89fba4712a"
+
+PV .= "+${UBRANCH}+"
+