meta-ibm: p10bmc: add a MCTP DISTRO_FEATURES switch

The switch enables AF_MCTP and adds the `mctp` tool and `mctpd` so we
can setup and manage an in-kernel MCTP network.

Enable it for p10bmc and also add CONFIG_TUN so we can use a tun device
to transport packets between the kernel and the astlpc interface
implemented in libmctp.

Change-Id: I21d0af9e751f91975c760b4b4708b3b401b95417
Signed-off-by: Rashmica Gupta <rashmica@linux.ibm.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 4143f34..9ecd14d 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -66,6 +66,7 @@
 FEATURE_PACKAGES_obmc-telemetry ?= "packagegroup-obmc-apps-telemetry"
 FEATURE_PACKAGES_obmc-user-mgmt ?= "packagegroup-obmc-apps-user-mgmt"
 FEATURE_PACKAGES_obmc-user-mgmt-ldap ?= "packagegroup-obmc-apps-user-mgmt-ldap"
+FEATURE_PACKAGES_obmc-dmtf-pmci ?= "packagegroup-obmc-apps-dmtf-pmci"
 
 # FIXME: phosphor-net-ipmi depends on phosphor-ipmi-host !?!? and
 # cannot be built on core-qemu machines because of the dependency